RAKsmart美国服务器评测 服务器小常识 Rpm软件包和共享库依赖性

Rpm软件包和共享库依赖性

RAKsmart美国站群服务器推荐

SSL证书/HTTPS证书

当程序员生成rpm软件包时,ldd命令用于报告动态可执行文件软件包中所有动态可执行文件使用的所有共享库。另一个混乱是由下面的事实带来的:相同软件包中的不同动态可执行文件可能与相同的共享库软件包的不同版本进行链接。例如,Heartbeat软件包中的不同程序可能已经进行了开发,并动态链接到libc.so.6sonmae共享库文件的不同GLIBC版本。对rpm命令使用-q和–requires参数,可以看到rpm软件包需要的共享库的完整清单。例如,要看到Heartbeatrpm软件包所有的所需依赖性,请使用命令:

#rpm-q–requires-pheartbeat-1.x.x.i386.rpm

这产生了下面的报告:

sysklogd

/bin/sh

/bin/sh

/usr/bin/python

ld-linux.so.2

libapphb.so.0

libc.so.6

libc.so.6(GLIBC_2.0)

libc.so.6(GLIBC_2.1)

libc.so.6(GLIBC_2.1.3)

libc.so.6(GLIBC_2.2)

libc.so.6(GLIBC_2.3)

libccmclient.so.0

libdl.so.2

libglib-1.2.so.0

libhbclient.so.0

libpils.so.0

libplumb.so.0

libpthread.so.0

librt.so.1

libstonith.so.0

注意,在此报告中,libc.so.6soname是所需要的,此共享库必须支持使用GLIBC共享软件包版本号2.0、2.1、2.1.3、2.2和2.3进行链接的动态可执行文件。这是由下面的事实决定的:Heartbeat软件包中的不同动态可执行文件是针对不同版本的libc.so.6库的每个版本进行链接的。在了解了动态可执行文件、共享对象、soname和共享库软件包彼此是如何相关的后,下面准备来看这样的一个例子:当尝试安装rpm软件包,并且它由于依赖性错误而失败时,会发生什么。yum能够从指定的服务器自动下载RPM包并且安装,可以自动处理依赖性关系,并且一次安装所有依赖的软体包,无须繁琐地一次次下载、安装。

本文来自网络,不代表RAKsmart美国服务器 评测立场,转载请注明出处。
RAKsmart美国站群服务器推荐

美国服务器推荐

返回顶部